Resolved
All systems are not fully operational. AWS has reported that they are not seeing any latency issues and are fully operational.
Monitoring
We're seeing reliable recovery of functionality across Page Vault services.
AWS has made progress with mitigations in the US-EAST-1 region, and we're seeing recovery across multiple AWS services. Launches of new EC2 instances are succeeding in several Availability Zones, and networking issues are decreasing. Lambda invocation errors have also improved, though some intermittent function errors may remain.
AWS is still throttling system usage and some Page Vault features could be impacted. We're monitoring closely and will continue to provide updates as AWS works towards full restoration.
Identified
Amazon Web Services (AWS) is currently experiencing a regional service disruption impacting Page Vault’s infrastructure. This has resulted in degraded performance and failures across key capture tools. Impact: Users may experience the following:
Stalled captures made through the browser extension, the batch tool, or the site crawler - you will be able to kick off the captures, but they may not complete. You can monitor through "Job History."
Inability to launch the Page Vault Browser