Page Vault

Portal loading issues
Resolved·Partial outage

Issues have been fully resolved

Thu, Aug 21, 2025, 07:47 PM
(1 day ago)
·
Affected components
Portal
Updates

Resolved

Issues have been fully resolved

Thu, Aug 21, 2025, 07:47 PM

Monitoring

The cloudflare incident has been mostly resolved. We are monitoring recovery of the portal.

Thu, Aug 21, 2025, 07:39 PM

Identified

We identified the issue as a problem with Cloudflare causing widespread service disruption on Clerk and AWS

Thu, Aug 21, 2025, 06:54 PM(45 minutes earlier)

Investigating

Our customer portal performance is degraded with customers experiencing issues loading folders and pages.

Thu, Aug 21, 2025, 05:47 PM(1 hour earlier)
Powered by